Search found 9 matches

by JB2050
Tue Oct 09, 2018 4:58 pm
Forum: Report Bugs
Topic: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode
Replies: 7
Views: 886

Re: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode

Can someone from ESP please confirm that my findings above are correct? In particular, please confirm: Whether the ESP32 cannot operate as an asynchonous I2S slave like other I2S slave devices, including, I think, various Bluetooth A2DP receivers, and instead must be the supplier of the master clock...
by JB2050
Sun Oct 07, 2018 9:59 pm
Forum: Report Bugs
Topic: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode
Replies: 7
Views: 886

Re: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode

Possible solution Setting bit I2S_TX_DSYNC_SW in I2S_TIMING_REG using this: SET_PERI_REG_BITS(I2S_TIMING_REG(0), 0x1, 1, I2S_TX_DSYNC_SW_S); appears to have cured both the unwanted zeros appearing in the ESP32 I2S slave output data, and the phase sensitivity of the BCK and FS signals into the ESP32...
by JB2050
Sun Oct 07, 2018 9:23 pm
Forum: Report Bugs
Topic: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode
Replies: 7
Views: 886

Re: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode

The sample zeroing problem appears to be sample rate dependent. To recap: I have the ESP32 configured as an I2S slave and an STM32 an I2S master. I have configured the ESP32 APLL to generate the I2S MCLK for the STM32 I2S master. The STM32 supplies the I2S BCK and FS clocks to the ESP32. When the s...
by JB2050
Sun Oct 07, 2018 3:59 pm
Forum: Report Bugs
Topic: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode
Replies: 7
Views: 886

Re: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode

Even though the WS (FS) edges produced by my STM32 I2S interface change on the falling edge of BCK (SCK), which is correct, I'm getting crackling that is resolved when WS is delayed slightly by adding a small capacitor (22pF to 100pF) after the 330R resistor between the STM32 and the ESP32 (or by to...
by JB2050
Sun Oct 07, 2018 3:18 pm
Forum: Report Bugs
Topic: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode
Replies: 7
Views: 886

Re: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode

Is there any way to input a MCLK into the ESP32 for use by (one of) its I2S interfaces (as with many DACs, PAs, etc)?

If so, that would solve my problem nicely.
by JB2050
Sun Oct 07, 2018 12:05 pm
Forum: Report Bugs
Topic: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode
Replies: 7
Views: 886

Re: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode

Given that excerpt from the technical reference manual "When ESP32 I2S works in slave mode, the master must use I2Sn_CLK (MCLK) as the master clock and fi2s>= 8*fBCK.", I tried outputting the ESP32 I2S0_CLK to IO0 and using that to clock the STM32 I2S (SAI) interface. Zeros are still present. Howeve...
by JB2050
Sat Oct 06, 2018 11:02 pm
Forum: Report Bugs
Topic: I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode
Replies: 7
Views: 886

I2S: Samples incorrectly zeroed when I2S interface is in slave mode but not master mode

Hello I want an ESP32 to output I2S data with its I2S0 interface in slave mode. I'm finding that with the I2S interface in master mode, the Tx data is correct. However, with it in slave mode, and the BCK and WS (FS) clocks supplied from an SAI interface (configured for I2S) in an STM32F767 MCU, some...
by JB2050
Mon Feb 12, 2018 11:54 am
Forum: General Discussion
Topic: Use of GPIO34 - 39 for I2C?
Replies: 6
Views: 1764

Re: Use of GPIO34 - 39 for I2C?

I confirm that with this change:
  • The spi_bus_initialize() call completes without error.
  • The SPI port works correctly, including inputing data from input-only (GPI) ports.
JB.
by JB2050
Sun Feb 11, 2018 4:48 pm
Forum: General Discussion
Topic: Use of GPIO34 - 39 for I2C?
Replies: 6
Views: 1764

Re: Use of GPIO34 - 39 for I2C?

Mapping e.g. the MISO pin of SPI to them would work because (unless you use quad-IO SPI mode) that always is an input. With the current ESP-IDF V3.0, I'm finding that this doesn't work. I'm trying to use GPI34 as a SPI MISO input. If I understand correctly what is going on, the reason it doesn't wo...

Go to advanced search