ESP-Wrover-Kit and ADS1220

jano2358
Posts: 8
Joined: Mon Jul 02, 2018 12:03 pm

ESP-Wrover-Kit and ADS1220

Postby jano2358 » Tue Sep 18, 2018 1:16 pm

hi!

I have an ADS1220 connected to the spi bus of the Wrover kit, wired as follows:

Code: Select all

ADS1220 || Wrover-Kit CLK > CLK MISO > SD0 MOSI > SD1 CS > CMD DRDY > IO16
The problem is when If I load any program to the board and the spi is connected, the board won't boot, I tried to disconnect the power from the ADS, connect a strong (1k) pull up to CS pin with and without disconnecting the CS from the Wrover and no success. It will only boot if the CLK and MISO are disconnected, I can connect them later, but not a the boot time. I was unable to test yet if I can communicate with the ADS.
If I connect the MISO and CLK and try to boot I get this messages on the serial port:
rst:0x10 (RTCWDT_RTC_RESET),boot:0x3e (SPI_FAST_FLASH_BOOT)
flash read err, 1000
ets_main.c 371
ets Jun 8 2016 00:22:57

If I disconnect CLK, then I get:
rst:0x10 (RTCWDT_RTC_RESET),boot:0x3e (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:952
load:0xffffffff,len:-1
ets Jun 8 2016 00:22:57

If I connect CLK and disconnect MISO:
rst:0x10 (RTCWDT_RTC_RESET),boot:0x3e (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:952
load:0x40078000,len:6084
load:0x40080000,len:7936
csum err:0x93!=0xd7
ets_main.c 371
ets Jun 8 2016 00:22:57

in any case the digital power of the ADS matters.
Any Idea of what can be the cause of this?

jano2358
Posts: 8
Joined: Mon Jul 02, 2018 12:03 pm

Re: ESP-Wrover-Kit and ADS1220

Postby jano2358 » Tue Sep 18, 2018 2:28 pm

Also if I attach an oscilloscope on SCK I can measure some 40MHz activity at the boot time, what is happening there?

ESP_Sprite
Posts: 1987
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP-Wrover-Kit and ADS1220

Postby ESP_Sprite » Wed Sep 19, 2018 4:28 am

The CLK, SDx, etc lines you connected your ADS1220 to are used to connect the ESP32 to its flash chip, where the code is stored. (See e.g. the datasheet of the ESP-Wrover for the connections.) Suggest you use different pins; at the moment there's no software support for using the flash pins for anything but flash.

Return to “Hardware”

Who is online

Users browsing this forum: jeanbie and 7 guests