ESP32-WROVER-KIT v.4.1 and JTAG with openocd don't recognize the ESP32

alessandro.bilato
Posts: 1
Joined: Wed Oct 10, 2018 1:18 pm

ESP32-WROVER-KIT v.4.1 and JTAG with openocd don't recognize the ESP32

Postby alessandro.bilato » Wed Oct 10, 2018 2:03 pm

Dear all,
me and my colleague need a help, we've been trying for two days and we have search everything but at the end
we are not able to use our two boards of ESP-WROVER-KIT V.4.1 for debug with openocd, some points
- upload a test FW like hello_world or blink works fine and the programs runs
- we have followed the Espressif tutorial step by step, and others found on internet
- controlled tens times the jumpers (same settings in the photo of the tutorial)
- nothing connected to the pins strip
- reinstalled the drivers
- used both USB and an external power source
- .. a lot more
nothing, we are convinced that it is a trivial oversight but we are not able to find it.
When we launch at command line with the command :

bin/openocd -s share/openocd/scripts -f interface/ftdi/esp32_devkitj_v1.cfg -f board/esp32-wrover.cfg

this is the output :

Open On-Chip Debugger 0.10.0-dev (2018-07-24-09:39)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
none separate
adapter speed: 20000 kHz
esp32 interrupt mask on
Info : ftdi: if you experience problems at higher adapter clocks, try the command "ftdi_tdo_sample_edge falling"
Info : clock speed 20000 kHz
Error: JTAG scan chain interrogation failed: all ones
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: esp32.cpu0: IR capture error; saw 0x1f not 0x01
Warn : Bypassing JTAG setup events due to errors
Info : esp32: Debug controller was reset (pwrstat=0xFF, after clear 0xFF).
Info : esp32: Core was reset (pwrstat=0xFF, after clear 0xFF).
....

the problem is the same in both board.

anyone have any suggestion ?

thank you in advance.

ESP_Sprite
Posts: 1941
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP32-WROVER-KIT v.4.1 and JTAG with openocd don't recognize the ESP32

Postby ESP_Sprite » Thu Oct 11, 2018 2:51 am

Fwiw, 'Error: JTAG scan chain interrogation failed: all ones' indicates the JTAG hardware (and software and drivers) are all OK; there's something physically wrong with the communication between the JTAG-chip and the ESP32. Some things that may cause this would be not having any jumpers on the header near the EN button (that header connects the JTAG pins to the ESP32) or having a program in the ESP32 that reconfigures GPIO12-15 to something else.

Who is online

Users browsing this forum: No registered users and 5 guests