Problem with ESP-WROOM-32 and WiFi

stefanoxjx
Posts: 23
Joined: Mon Feb 12, 2018 6:26 pm

Problem with ESP-WROOM-32 and WiFi

Postby stefanoxjx » Mon Feb 12, 2018 6:37 pm

Hi, I'm studying ESP-WROOM-32 and I've a problem with all programs that needs of WiFi.
I'm use esp-idf and I tried to upload all examples that needs of wifi (/esp-idf/examples/wifi) and all have the same problem.
If I try to use for example blink or hello_world (/esp-idf/examples/get-started), them works fine.
When I turn on the module after uploaded the program, trough the serial monitor I see these messages recursively:

Code: Select all

ets Jun 8 2016 00:22:57
rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff0018,len:4
load:0x3fff001c,len:5664
ho 0 tail 12 room 4
load:0x40078000,len:0
load:0x40078000,len:13904
entry 0x40078fd8
I (30) boot: ESP-IDF v3.1-dev-355-g35de8d7-dirty 2nd stage bootloader
I (30) boot: compile time 15:23:49
I (32) boot: Enabling RNG early entropy source…
I (37) boot: SPI Speed : 40MHz
I (41) boot: SPI Mode : DIO
I (45) boot: SPI Flash Size : 4MB
I (49) boot: Partition Table:
I (53) boot: ## Label Usage Type ST Offset Length
I (60) boot: 0 nvs WiFi data 01 02 00009000 00006000
I (68) boot: 1 phy_init RF data 01 01 0000f000 00001000
I (75) boot: 2 factory factory app 00 00 00010000 00100000
I (83) boot: End of partition table
I (87) esp_image: segment 0: paddr=0x00010020 vaddr=0x3f400020 size=0x0f1bc ( 61884) map
I (117) esp_image: segment 1: paddr=0x0001f1e4 vaddr=0x3ffb0000 size=0x00e2c ( 3628) load
I (119) esp_image: segment 2: paddr=0x00020018 vaddr=0x400d0018 size=0x55080 (348288) map
0x400d0018: _stext at ??:?
I (245) esp_image: segment 3: paddr=0x000750a0 vaddr=0x3ffb0e2c size=0x02370 ( 9072) load
I (248) esp_image: segment 4: paddr=0x00077418 vaddr=0x40080000 size=0x00400 ( 1024) load
0x40080000: _iram_start at /dati/common/esp32/esp-idf/components/freertos/./xtensa_vectors.S:1685
I (252) esp_image: segment 5: paddr=0x00077820 vaddr=0x40080400 size=0x0e010 ( 57360) load
I (284) esp_image: segment 6: paddr=0x00085838 vaddr=0x400c0000 size=0x00000 ( 0) load
I (293) boot: Loaded app from partition at offset 0x10000
I (293) boot: Disabling RNG early entropy source…
I (293) cpu_start: Pro cpu up.
I (297) cpu_start: Starting app cpu, entry point is 0x40080f58
0x40080f58: call_start_cpu1 at /dati/common/esp32/esp-idf/components/esp32/./cpu_start.c:215
I (289) cpu_start: App cpu up.
I (308) heap_init: Initializing. RAM available for dynamic allocation:
I (314) heap_init: At 3FFAE6E0 len 00001920 (6 KiB): DRAM
I (321) heap_init: At 3FFB8E58 len 000271A8 (156 KiB): DRAM
I (327) heap_init: At 3FFE0440 len 00003BC0 (14 KiB): D/IRAM
I (333) heap_init: At 3FFE4350 len 0001BCB0 (111 KiB): D/IRAM
I (340) heap_init: At 4008E410 len 00011BF0 (70 KiB): IRAM
I (346) cpu_start: Pro cpu start user code


I don't understand what's the problem :(
Can you help me?
Many thanks.

Best regards.

ESP_Sprite
Posts: 1567
Joined: Thu Nov 26, 2015 4:08 am

Re: Problem with ESP-WROOM-32 and WiFi

Postby ESP_Sprite » Tue Feb 13, 2018 4:25 am

What hardware are you using? Are you sure the ESP32 gets enough power? At least 500mA is recommended.

stefanoxjx
Posts: 23
Joined: Mon Feb 12, 2018 6:26 pm

Re: Problem with ESP-WROOM-32 and WiFi

Postby stefanoxjx » Tue Feb 13, 2018 10:03 am

Hi, thanks for your reply.
I'm using this module:
Image
and powering by supplier 3.3V 5A.
I tried to use another power supply, but the problem still present.
I placed too a capacitor 330uF.

Stefano

ESP_Sprite
Posts: 1567
Joined: Thu Nov 26, 2015 4:08 am

Re: Problem with ESP-WROOM-32 and WiFi

Postby ESP_Sprite » Wed Feb 14, 2018 5:38 am

Problems like this usually happen when the power supply isn't good enough; the WiFi calibration will cause the module to brown out and reset. Where did you put the 330uF capacitor? If it's too far away from the Wroom32, the brown-out may still happen. If you have an oscilloscope, you may also want to put that on the 3.3V input pads of the WROOM32 and trigger on, say, 3.0V, to see if the module really doesn't brown out.

stefanoxjx
Posts: 23
Joined: Mon Feb 12, 2018 6:26 pm

Re: Problem with ESP-WROOM-32 and WiFi

Postby stefanoxjx » Wed Feb 14, 2018 8:40 am

Hi,
The 330uF capacitor were applied after I've seen the problem.
I've solved this problem changing esp module.
With another module the problem there isn't.

Who is online

Users browsing this forum: No registered users and 3 guests