Page 2 of 2

Re: Build tools for 32-bit Linux

Posted: Fri Feb 03, 2017 6:17 am
by Ritesh
kolban wrote:You can download the Linux 64 bit compiled toolchain from here:

https://dl.espressif.com/dl/xtensa-esp3 ... 2.0.tar.gz

See the following docs:

http://esp-idf.readthedocs.io/en/latest ... -the-esp32

However, the link for the 32 bit compiled toolchain is not working as of the date of this post and there is an open issue to resolve that .. see:

https://github.com/espressif/esp-idf/issues/279


Hi,

Thanks for Reply.

Yes. I have also seen above link which you have forwarded in which someone has mentioned that he is not able to download 32bit toolchain which is required to compile application with latest ESP32-idf release SDK.

So, Do you have idea when they will release 32 bit based Toolchain as I need to switch to 64 bit machine or need to install virtual system with 64 bit system to compile my application with latest ESP32-idf SDK?

Please let me know if anyone has any informations for that.

Re: Build tools for 32-bit Linux

Posted: Fri Feb 03, 2017 6:31 am
by ESP_Angus
The 32-bit toolchain download link has been fixed. Sorry for the inconvenience.

Re: Build tools for 32-bit Linux

Posted: Fri Feb 03, 2017 6:46 am
by Ritesh
ESP_Angus wrote:The 32-bit toolchain download link has been fixed. Sorry for the inconvenience.


Thanks for fixing Link.

Re: Build tools for 32-bit Linux

Posted: Fri Feb 03, 2017 12:01 pm
by luca.gamma
ESP_Angus wrote:The 32-bit toolchain download link has been fixed. Sorry for the inconvenience.


Thanks for this fix :)

Re: Build tools for 32-bit Linux

Posted: Mon Feb 12, 2018 7:45 pm
by LudoDr
I'm getting the same warnings here

WARNING: Toolchain version is not supported: 1.22.0-61-gab8375a
Expected to see version: 1.22.0-80-g6c4433a
Please check ESP-IDF setup instructions and update the toolchain, or proceed at your own risk.

I'm using Linux 64bit

update all with git pull
git submodule update
make clean; make defconfig; make all
can you help please?

Re: Build tools for 32-bit Linux

Posted: Tue Feb 13, 2018 4:09 am
by ESP_Angus
LudoDr wrote:I'm getting the same warnings here

WARNING: Toolchain version is not supported: 1.22.0-61-gab8375a
Expected to see version: 1.22.0-80-g6c4433a
Please check ESP-IDF setup instructions and update the toolchain, or proceed at your own risk.


You have an older version of the toolchain, it's been updated since you installed it. You can find a link to the latest version here:
https://esp-idf.readthedocs.io/en/lates ... hain-setup

Angus