Building Simple OTA flash for ESP32

4310.benno
Posts: 3
Joined: Mon Feb 11, 2019 3:32 pm

Building Simple OTA flash for ESP32

Postby 4310.benno » Tue Feb 12, 2019 8:57 am

Hi,
I am trying to create the Simple OTA flash for my ESP32. When I needed to flash my ESP8266 some time ago, I was able to simple download the required bin files, and flash is with the ESP download tool. Since I am unable to find "ready to go" bin files, I decided to try and generate them myself by using VS2010 & VisualGDB plugin (offering more settings I will ever need).

On building the project I receive an error :
Command exited with code 1
Executable: C:\Users\benno\AppData\Local\VisualGDB\CMake\bin\cmake.exe
Arguments: ../.. -G "Ninja" -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_COLOR_MAKEFILE=OFF -DCMAKE_MAKE_PROGRAM="C:/Program Files (x86)/Sysprogs/VisualGDB/ninja.exe"
Directory: c:\users\benno\documents\visual studio 2010\Projects\EmbeddedProject1\EmbeddedProject1/VisualGDB/Release
VisualGDB: Error: Command-line action failed

The error list shows :
Error 1 Cannot specify link libraries for target "simple_ota" which is not built by C:\SysGCC\esp32\esp-idf\v3.2\tools\cmake\idf_functions.cmake 211 0

So there error should be somewhere in the idf_functions.cmake?

I there anyone out there who can give a hand or suggestions?

mikemoy
Posts: 243
Joined: Fri Jan 12, 2018 9:10 pm

Re: Building Simple OTA flash for ESP32

Postby mikemoy » Tue Feb 12, 2019 1:17 pm

It looks like when you created your new project you selected CMake. That one is buggy as hell.
Instead choose "GNU Make". This one works like a charm!
I exclusively use Visual GDB on a daily basis with ESP32 and its just awesome.
One the build is successful, you will find your .bin files in the Release or Debug folders. Depends on what you selected when you built it.

4310.benno
Posts: 3
Joined: Mon Feb 11, 2019 3:32 pm

Re: Building Simple OTA flash for ESP32

Postby 4310.benno » Tue Feb 12, 2019 4:40 pm

Forgot never to use "Recommended" on Microsoft.....
Working and solved.
Thanks

4310.benno
Posts: 3
Joined: Mon Feb 11, 2019 3:32 pm

Re: Building Simple OTA flash for ESP32

Postby 4310.benno » Tue Feb 12, 2019 8:08 pm

You are right, never try "recommended" with Microsoft
Solved, working now
Thanks

Return to “General Discussion”

Who is online

Users browsing this forum: ESP_Sprite, Google [Bot] and 21 guests