CONFIG_CONSOLE_UART_NONE - UART Disable

Rx-365
Posts: 8
Joined: Wed Jan 17, 2018 12:08 am

CONFIG_CONSOLE_UART_NONE - UART Disable

Postby Rx-365 » Fri May 17, 2019 3:25 pm

Quick question about the setting in make menuconfig. I use UART2 to communicate with a peripheral device. This UART is configured and set up within application code. However, I do not want the normal ESP Log Messages to be sent out over any UART. I set CONFIG_CONSOLE_UART_NONE within make menuconfig and built/programmed the bootloader, partition table and application.

At this point UART2 no longer functions. Why does CONFIG_CONSOLE_UART_NONE kill all uart capabilities and not simply the ESP console output? What is the better way to achieve this?

Ritesh
Posts: 902
Joined: Tue Sep 06, 2016 9:37 am
Location: India
Contact:

Re: CONFIG_CONSOLE_UART_NONE - UART Disable

Postby Ritesh » Fri May 17, 2019 9:48 pm

Rx-365 wrote:
Fri May 17, 2019 3:25 pm
Quick question about the setting in make menuconfig. I use UART2 to communicate with a peripheral device. This UART is configured and set up within application code. However, I do not want the normal ESP Log Messages to be sent out over any UART. I set CONFIG_CONSOLE_UART_NONE within make menuconfig and built/programmed the bootloader, partition table and application.

At this point UART2 no longer functions. Why does CONFIG_CONSOLE_UART_NONE kill all uart capabilities and not simply the ESP console output? What is the better way to achieve this?
Hi,

Which ESP32 IDF you are using? And we are also using UART1 and UART2 as per our requirement.

So, Why you want to disable debug logs on console UART? And I believe that CONFIG Console UART None will just disable console UART.

Please share you sample code as well.
Regards,
Ritesh Prajapati

Rx-365
Posts: 8
Joined: Wed Jan 17, 2018 12:08 am

Re: CONFIG_CONSOLE_UART_NONE - UART Disable

Postby Rx-365 » Mon May 20, 2019 6:13 pm

The issue is also described here: https://github.com/espressif/esp-idf/issues/2013. I am disabling the console output because I do not want to any of the information on it to be visible to any probing.

I imagine that the setting should simply leave UART0 uninitialized or disable UART0. I don't understand why it currently disables all UARTs (0,1,2) and does not allow application code to utilize them.The IDF version is 3.2, however I believe that this will be present across all earlier versions due to the above issue.

At this point I don't understand whether this is a bug or the intended operation of the setting.

Ritesh
Posts: 902
Joined: Tue Sep 06, 2016 9:37 am
Location: India
Contact:

Re: CONFIG_CONSOLE_UART_NONE - UART Disable

Postby Ritesh » Mon May 20, 2019 6:30 pm

Rx-365 wrote:
Mon May 20, 2019 6:13 pm
The issue is also described here: https://github.com/espressif/esp-idf/issues/2013. I am disabling the console output because I do not want to any of the information on it to be visible to any probing.

I imagine that the setting should simply leave UART0 uninitialized or disable UART0. I don't understand why it currently disables all UARTs (0,1,2) and does not allow application code to utilize them.The IDF version is 3.2, however I believe that this will be present across all earlier versions due to the above issue.

At this point I don't understand whether this is a bug or the intended operation of the setting.
Ok. Let me check by disabling Debug Console UART and see it will create any impact to UART1 and UART2 or not.

If it is really issue then it might be fixed earlier. Still, ESP32 SDK developers can also confirm for same.
Regards,
Ritesh Prajapati

Who is online

Users browsing this forum: Bing [Bot], vjacobs and 12 guests